Mozilla and IE Text Editor

requires Mozilla 1.3 on Windows, Macintosh, Linux, etc. or IE4+/Win.

What it does: Adds appropriate HTML tags to text in <textarea> form fields.

Just for Mozilla 1.1+ testing:

Brought to you by

(...after using some of the nifty graphics and CSS stylings of Megnut's toolbar. Created by Meg herself.)

(P.S. Matt mentioned that this code didn't include a pony. So I added one by changing Meg's nice javascript keyboard controls to also accommodate Mozilla 1.1+ users. However - you should know that although it tested fine on Windows 2000 - I'm not sure about how the keypress capture handles on other platforms yet...)